Lightning Rodder banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2,334 Posts
Discussion Starter · #1 ·
I'd greatly appreciate it if someone could help me out trying to track down the cause of a P0174 code.

I've tried everything but switching out my MAF.

If you have a spare one, please send it my way. I'll swap mine out with yours and clear the code, and see if the code stays off.

If it does, I'll gladly pay your asking price for the MAF. If the code stays, I'll send the MAF back to you and pay shipping both ways.

Thanks
 

·
Forced Induction Or Die!
Joined
·
1,167 Posts
Mines been doing the exact damn thing. I cleaned it but light came back on. Mines under warranty but I would rather fix the shit myself then somebody at a stealership to Touch my truck.


---
- Sent from my iPhone
 

·
Registered
Joined
·
2,334 Posts
Discussion Starter · #7 ·
I cleared P0174 by giving my current MAF a very thorough cleaning. Just go to advanced auto parts and buy some MAF cleaner.
I did that. When I cleaned the MAF it was the longest the code stayed off, came back after about a 20 minute drive.

That's why I'm thinking the MAF is bad.

I'm gonna clean it again, maybe I didn't get it good enough, but I doubt it.

Bump this to the top, I'd really appreciate the help.
 

·
Forced Induction Or Die!
Joined
·
1,167 Posts
Mine stayed off for a full day of normal driving then came back on.


---
- Sent from my SACK!
 

·
Registered
Joined
·
6,328 Posts
i'll trade you my stock HD rims for your stock L rims. And I will include all the curb rash.
I've got some '02's....hmmm you paying shipping?
Bump for Toastman!
 

·
Registered
Joined
·
9,499 Posts
I've got some '02's....hmmm you paying shipping?
Bump for Toastman!
funny thing.... 02s used to be my favorites back in the day, now they are my least favorite. 03/04s i think look the best but there's something about the 99/00 that I really like.


Shit, my banged up HD rims for 02s? They'd have to have DRs and you pay shipping! Mine might be scratched up but they're still worth something! Plus I've still got a good 99% tread on the wear-proof hankooks!
 

·
Registered
Joined
·
2,334 Posts
Discussion Starter · #14 ·
toastman check this thread out - it sounds to me like your MAF is not the problem, but the PVC elbow mentioned in this thread could be your

http://www.lightningrodder.com/forum/showthread.php?t=68671
Thanks man...but been there and done that, and I have the cuts and burns to prove it (yeah I did that shit with the supercharger on) and the code just came right back on after 2 miles.

The longest the code has stayed off was when I douched the MAF which is leading me to believe it's a problem with the sensor
 
1 - 14 of 14 Posts
Top