Lightning Rodder banner
1 - 20 of 31 Posts

Registered
Joined
13 Posts
Discussion Starter · #1 ·
Been a long bumpy road and have been hard at it trying to figure this issue out. When the truck stalls it makes a loud wine which cough my attention. I'm hoping it's simple vacuum line and the way I have my supercharger vacuum hoses ran.
My lightning has been setting for 2 years do to oem / remanufactured kb2.3 factory plumbed along with egr delete. Truck was running fine just before I decided to clean out the turkey pan along with visual inspection of the supercharger and noticed the units main moving parts were rubbing on it's casing. So truck sat.

I just bought a new supercharger. The true kb2.6L assembly which is quite different yet the same. Main difference being the mammoth throttle body and perhaps the factory vacuum lines are slightly different.

Drained the fuel using my fuel pump then changed filter and fresh 93 gas
I inspected all grounds and cleaned
Fuel pressure reads 40 and if I hold the gas peddle to the floor the truck will run for a few seconds and fuel pressure does go up to 50 psi or so.

I cleaned the idle thing on the top passenger side of sc

I inspected the fuel pump resistor and its resistance was next to nothing and unit was replaced not to many miles ago.

Engine was finally all broken in @3,000 miles and its a completely new engine 100% new everything

Mind you my mechanical background is run off YouTube and use basic probe and test light and I take good direction 馃ぁ

Truck has a sct chip under glove box and was tuned and ran well with my old supercharger. New 80lb injectors and high grade fuel pumps.
Sct mas air. New exhaust 馃い and 02 sensors. Coils don't have to many miles on them and there ngk and new ngktr6 plugs
Font Art Parallel Drawing Illustration
 

Wile E. Coyote, Super Genius!
Joined
11,545 Posts
Well, sounds like a plenum leak to me. When that leaks, it makes a loud whine and runs like poo. Also, I have an oil separator on mine. It has a petcock on the bottom to drain it. My usual MO is to put a rattle can lid under it, open it and walk away. Several times, I forgot it was open, and started the truck. Runs bad, cough and spits, real jerky in gear. Did it yesterday. Hurr Durr!!
 

Registered
Joined
13 Posts
Discussion Starter · #4 ·
Not gonna lie, I tightened the main long bolts down as I always have. But now with this big blower I need to actually tq them correctly. 馃槵 thank you!!!! Actually can picture that sound now escaping from below the supercharger 馃槤 pewww 馃樂馃
 

Registered
Joined
926 Posts
What the heck do you have for an intake tube?

Sent from my Pixel 6 Pro using Tapatalk
 
  • Like
Reactions: utlong31

regular joe
2002 True Blue
Joined
2,008 Posts
Im confused. Truck has an sct chip and was tuned for old supercharger.

Now it has 80lb injectors (i assume it had 80s before). Did you get retuned for the new 2.6?
 
  • Like
Reactions: utlong31

Registered
Joined
38 Posts
Anxiety? I haven't been on this site long at all, but thats the nicest i've ever seen Dusten word something. :ROFLMAO:

How does something as "organized" as the picture in the first post, turn into the picture in the third post?
 

Wile E. Coyote, Super Genius!
Joined
11,545 Posts
Anxiety? I haven't been on this site long at all, but thats the nicest i've ever seen Dusten word something. :ROFLMAO:
He must be off his meds this morning. :LOL:
 

Wile E. Coyote, Super Genius!
Joined
11,545 Posts
Wouldn't it be the other way around?
Maybe your meds make you grouchy? And when you forget to take them, you get civilized? ;-)
 

Registered
Joined
13 Posts
Discussion Starter · #12 ·
Problem solved. On my part and out of sight. The two part intake manifold wasn't mated up properly. There was a .250 gap out of sight do to my .250 shim that was hitting on that long stud on that driver side far back bolt. Trucks running like new and no more peww.
Motor vehicle Hood Automotive exterior Vehicle Electrical wiring
 

Wile E. Coyote, Super Genius!
Joined
11,545 Posts
I bet there's a bird nest in there somewhere.
Vehicle Car Automotive tire Hood Automotive lighting
 

Registered
Joined
13 Posts
Discussion Starter · #19 ·
@Ryan205211 Is that really some janky-ass fan, that looks to be missing a blade, mounted under your hood, which appears to have a hole cut in it and a 'junkyard cowl hood'?

That explains a lot... :eek:
The fans not missing a blade 馃 the fan actually rips the air right out the vent. Trucks runs flawlessly Aman. I definitely appreciate all the lovely, feed back and very thankful you all pin pointed my issue. Thank ya
 

Wile E. Coyote, Super Genius!
Joined
11,545 Posts
Fan isn't missing any blades. It's just the angle of the dangle that makes it appear to be missing a blade. Cool man! Using a fan so suck the air out from the engine compartment. Who'da thunk it. Come on man! Post a pic of the whole truck. We're all dying to see it. Here's one I spotted one day.
Wheel Tire Cloud Car Land vehicle
 
1 - 20 of 31 Posts
Top