Lightning Rodder banner
1 - 3 of 3 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
Has anyone had a problem with the tranny not shifting down whenyou're babying it? For the last 6-9 months I've noticed mine just doesn't want to easily shift into a lower gear without giving more gas than would really be necessary. This has happened with a chip in it with the pressure turned up and without the chip at all. I'm running a 4# pulley at this time is the only real mod I have. Any suggestions it's not throwing any codes and shifts up fine from a dead stop and it's not slipping as far as I know. [smilie=fingersx.gif]
 

·
Registered
Joined
·
367 Posts
Bill Jordan said:
Has anyone had a problem with the tranny not shifting down whenyou're babying it? For the last 6-9 months I've noticed mine just doesn't want to easily shift into a lower gear without giving more gas than would really be necessary. This has happened with a chip in it with the pressure turned up and without the chip at all. I'm running a 4# pulley at this time is the only real mod I have. Any suggestions it's not throwing any codes and shifts up fine from a dead stop and it's not slipping as far as I know. [smilie=fingersx.gif]
The first thing I will tell you is that the shift down feature is MPH regulated not RPM driven. If you are running a stock tune you will be in OD around 45 MPH and it will not kick down until you reach the 25ish MPH mark. Line pressure has nothing to due with the downshift. The one way to correct this issue if it is for you is to have your tune rewritten to account for the downshifting.

I have mine to down shift at 35 MPH and upshift from second to third at 40 MPH.

I hope this helps. I am not an expert I have just ran into this issue with my stock tranny and now I have a built one with a 2800 stall.
 

·
Registered
Joined
·
270 Posts
i have the same problem but i dont want it to shift down then the blower whine dies down with it. [smilie=laugh.gif]
 
1 - 3 of 3 Posts
Top