Lightning Rodder banner
1 - 19 of 19 Posts

·
Premium Member
Joined
·
13,857 Posts
Discussion Starter · #1 ·
WERE GETTING THERE NOW,
WOO HOO
THANKS SAL  :D























I found out some more very interesting facts today:
Since I don't remember the exact #'s I won't quote them, hehehehehe
But

Beside the Deck being Warped and Bowed, (the worse point being right where they all leak oil, Sal ponted it out and found it very interesting since it's a known troubled area) 

ALSO
One side had a deck height way lower than the other.

I know some seem to think these mis-matches are minor, "but I don't"
It's a wonder these things can stay sealed at all with the mis-matched deck heights, and warped Head Surfaces Area, (it's got me convinced ""it came like that"")

The one area I was blown away by, was how much of the heads were eating away around the spark plug area's. (the pic's do it no justice) Yet the pistons and valves show NO LEAN CONDITIONS were present AT ALL. This leads me to believe that was done quite some time ago, I'm going to guess it was the day I had the 3 plug melt down on the 1320. I have never before NOR AFTERWARDS experienced Detonation, but let me tell you, when it happen there was no asking, WHAT DOES DETONATION SOUND LIKE. It sounded like 8 midgets were whaling the fire wall with sledge hammers
OR SOMETHING???

All I can say is, IT'S 100% PERFECT AND WITHIN PROPER SPEC NOW, FROM HEAD TO TOE :D
And most likely, for the first time ever. And some may have noticed I now have like 15 Threads in my Heads for Spark Plugs, YIP YIP YIPPY YIA (and a got dam good job at that I may add)

I can not tell you how amazing Sal has been, he has explained and shown me each and every single detail and issue along the way. I also cant tell you how amazing it is to be able to check in on it at lunch time and chew the fat with Sal. He sat there today and showed me the screwed up Valve Guides, all my old bolts are baged and were shown to me, the Rod Bearings (ALL PERFECT BTW : o ) we once again inspected the old pistons, rods, and rings, (couldnt ask them to look better), as you see the valves are flawless. It seems the Block and Decking problems are clearly factory problems (and mine was still sealed 100% even with the probs) It also seems the eating away of the heads was old and not new (thats good news) and I'll end this by saying, I HAVE LEARNED SO FRIGGING MUCH BY THIS AND I LOVE IT.

THANKS PSP,  :cheers:
Sal you truly are the Best   [smilie=bow.gif]
 

·
Premium Member
Joined
·
4,662 Posts
Rob,

The pics look FANTASTIC! :smt023 The LR low budget 10 sec. beast is really coming into play now :smt038

That is soooooo trippyyyyy about the heads getting eaten away like that. I love the modmax pistons btw, and what about the cams? I remember you mentioned that you were going to use stock cams, am I correct?

D000000000000d I am building the boost up to get another story for the LR e-zine after you get the LR 10 sec beast running... Sal will definitely have my business for the project I have in mind [smilie=dancingnaughty.gif]

Rob your engine LOOKS BEAAAUUUUTTTTTIIIFFFUUULLLL  :smt055

TIME TO CELEBRATE, PARTTTTYYYY ATTTTT RooooOOooooBBBBBB'ssssss!  [smilie=party.gif] [smilie=bowlaugh.gif]
 

·
Registered
Joined
·
202 Posts
Looks great Rob and one of the best doing it for you!

" I have never before NOR AFTERWARDS experienced Detonation, but let me tell you, when it happen there was no asking, WHAT DOES DETONATION SOUND LIKE. It sounded like 8 midgets were whaling the fire wall with sledge hammers
OR SOMETHING???"

You crack me up!!!!!!! :D

Jody
 

·
Project Dirty Dog
Joined
·
6,747 Posts
Nice looking motor
 

·
Registered
Joined
·
85 Posts
That looks badd azz, would look great in my engine bay as well.
 

·
Registered
Joined
·
393 Posts
I'm glad you showed such detail of your internals....it will be much easier to identify them later when we are picking them up off the track....LOL!

J/K buddy...Looks great, I can see Sal is doing a great job with your engine/truck. Can't wait to see your first post after a 10 sec run!!
 

·
Registered
Joined
·
393 Posts
It looks like it to me, that's the first thing I noticed....Reminds me of my old 427 side oiler days!! Although the FE only had cross bolted caps on the center three mains, looks like the mod motor has them on all!!
 

·
Premium Member
Joined
·
13,857 Posts
Discussion Starter · #15 ·
YEP, and to tell you the truth, I didn't even know we had them, and when I asked Sal about it, he referenced the old 427 too :D
 

·
Registered
Joined
·
393 Posts
I guess the 5.4L Mod motor is in good company! I believe the only other motors that were ever cross-bolted were the 427 FE and the 426 Hemi. Those are the only two engine families that have the block skirt that comes down below the crank so that it could be cross bolted!!
 

·
Registered
Joined
·
218 Posts
Looks like quite abit of detonation was working on those heads [smilie=eek4.gif]

Wonder if it could have been to much timing..........nah [smilie=omgrofl.gif]
 

·
Registered
Joined
·
85 Posts
Great Looking motor, cant wait to see those times
 
1 - 19 of 19 Posts
Top