Lightning Rodder banner

1 - 3 of 3 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
I decided to change my oem battery terminals since I thought it be a good idea to have them changed since they showed their age. I bought some battery terminals from autozone them clamp style ones and when I went to turn on truck I have od light flashing. Transmission harness has been inspected and no bends or burns even changed out my solenoid pack out and transmission oil was very red no metal shavings on magnet just normal dust from wear use. Transmission was rebuild with a circle d converter and never had issues until I messed with battery terminals.

Can terminals be the cause of this codes?

Truck moves in reverse but in drive it moves a little but feels like its moving from a very high gear. The moment I put it on manual 1st gear it moves effortlessly.

Codes I get are

P0743 Torque Converter Clutch Circuit Electrical

P0755 Shift Solenoid ‘B

P1747 Electronic Pressure Control Solenoid 'A' Short Circuit

P1754 Coast Clutch Solenoid Circuit

P1760 Overrun Clutch Solenoid Valve
 

·
11 second street truck
Joined
·
10,642 Posts
Did you check fuse 23?
 

·
Registered
Joined
·
229 Posts
Discussion Starter #3
Yes sir check fuse 23 everything good, I think my solenoid connector took a dump. when I disconnect the connector the codes stay the same on those solenoids but now trans temp solenoid code comes up when disconected, feel wires on the other pins are brittle with the heat and not getting power to solenoids.
 
1 - 3 of 3 Posts
Top