Lightning Rodder banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Im in need of some help lighting rodders, my 02 lightning has a check engine light with the P0358 & P0401 codes and cant seem to get down to the cause of them
(P0401 Exhaust gas recirculation flow insufficient detected). Cleaned egr, tube, upper elbow, egr valve control solenoid and code persist.
Ignition coil H primary/secondary circuit changed coil pack, spark plug, pigtail and code persists also
Checked other threads on this and cant seem to find the answer
Tips or ideas would be much appreciated!
 

·
Wile E. Coyote, Super Genius!
Joined
·
11,089 Posts
There is a black box on the driver's side that has two vacuum hoses on it and a plug. It's a DPFE. They go bad and cause the problem with insufficient flow. They're easy to replace and not expensive. Any auto parts shop will have them. Advance Auto, Auto Zone, NAPA and O'Reilly's have them here where I live.

If you live in a state that doesn't so smog checks, take the fool thing off. I did.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
There is a black box on the driver's side that has two vacuum hoses on it and a plug. It's a DPFE. They go bad and cause the problem with insufficient flow. They're easy to replace and not expensive. Any auto parts shop will have them. Advance Auto, Auto Zone, NAPA and O'Reilly's have them here where I live.

If you live in a state that doesn't so smog checks, take the fool thing off. I did.
I changed it and still has the same two codes, when i put the pedal to the metal it takes a while for it to pick up, whines but no go..
 

·
Registered
Joined
·
1 Posts
I changed it and still has the same two codes, when i put the pedal to the metal it takes a while for it to pick up, whines but no go..
Any luck with this? I have a persistent p0401. I've found the vacuum supply to the EGR valve during road tests never goes above 3in. I can't find an official tolerance for this, but it seems to me if the EVR isn't allowing sufficient vacuum to the EGR valve, then the valve won't open and this code will be the result. I've replaced the EVR, DPFE, and EGR valve out of desperation, but nothing seems to work
 
1 - 4 of 4 Posts
Top