Lightning Rodder banner
1 - 20 of 26 Posts

·
Registered
Joined
·
3,682 Posts
Discussion Starter · #1 ·
Out of the blue my odometer lights are out. Before I start researching, anyone have a quick fix or experience with this?
 

·
Cogs and Idlers
Joined
·
3,106 Posts
Pretty sure I read something on nloc where the wide plug that goes into the instrument cluster has a poor soldering job. You will need to pull it apart and fix the broken connection.
 

·
"01 Fastblack"
Joined
·
320 Posts
Out of the blue my odometer lights are out. Before I start researching, anyone have a quick fix or experience with this?
Yep it's a common problem with these trucks, mine goes out for a bit then magically comes back on just haven't felt like taking the dash apart to fix. I also was told it is a bad connector behind the dash. If you fix it please pass the how to info on to us. thanks
 

·
Registered
Joined
·
4,809 Posts
Yep, have to pull the cluster apart and solder the loose pin on the circuit board. The loose pin on the board runs from the harness plug. They vibrate loose and loose contact. Soldered mine a few years back. Look for videos on youtube
 

·
Registered
Joined
·
3,682 Posts
Discussion Starter · #8 ·
Yeah watched the video on it. Seems straight forward but looks like I'm taking the dash apart :smt013. ABS light is on from removing the ABS system. Any way to blank out the light for that while I am in there? Also the air bag light as well?
 

·
2.9 Whipple E85R A1 Transmission
Joined
·
12,064 Posts
Just remove the ABS light bulb...
Do not remove the air bag bulb, just paint it black.
 

·
Registered
Joined
·
66 Posts
Yep it's a common problem with these trucks, mine goes out for a bit then magically comes back on just haven't felt like taking the dash apart to fix. I also was told it is a bad connector behind the dash. If you fix it please pass the how to info on to us. thanks

Very easy fix. Follow the instructions found in the how-to section on the forum. Had mine out, soldered and back in and working in under an hour.
 

·
Registered
Joined
·
2,049 Posts
Just remove the ABS light bulb...
Do not remove the air bag bulb, just paint it black.
I tried to remove the light bulbs while back after installing everything back I heard a weird bell sound. Any idea why?
 

·
2.9 Whipple E85R A1 Transmission
Joined
·
12,064 Posts
If you pulled the Airbag light..you will get a 5 beep and it will repeat 5 times.
 

·
Registered
Joined
·
3,682 Posts
Discussion Starter · #14 ·
Lights are on now so I will just leave it alone. Maybe loose wire in circuit board solder joint?
 

·
Registered
Joined
·
16 Posts
Had this problem when I bought my L, this was one of the first fixes I did. The dash is pretty easy to take apart if you're a little mechanically inclined. Then resoldering pins is easy if you have a good soldering iron setup and a steady hand. You can shoot me a PM if you have questions on it, it's still pretty fresh in my memory.
 

·
Worlds Fastest Street HD Truck
Joined
·
14,677 Posts
its going to happen again Dude. Over time it'll be more frequent. Mine does it every once in a while and I just smack the dash and it comes back. Once that trick stops working or if I have it apart again, I'll fix it then.


as for the bulbs, paint them black, but do several coats or it'll illuminate very dimly still. It'll keep you from getting any beeping alarms
 

·
"Only god can judge me."
Joined
·
4,655 Posts
Its not just "loose" wires on the ribbon cable. You may take it apart and see teh wires appear to be solder but the problem is they are poor solder joints or "cold" jointys. They just need reflowed with some rosin core solder and you will be fine. Make sure your joints are shiney and not flat like u see when you pull it apart. Cluster is very easy to get out as in video.
 

·
Registered
Joined
·
291 Posts
I almost bought a truck with an odometer that was out most of the time. It was advertised to be at 80k miles. I hit it and got it to work and the mileage matched up. During the test ride I saw an old reciept in the glove box for brake rotors and other stuff at 79k miles. I looked outside and saw the brake rotors were completely shot again. Truck had been at 80k miles for over 5 years at least.
 
1 - 20 of 26 Posts
Top