Lightning Rodder banner

1 - 20 of 49 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
so im new to this form and just made this screen name to ask a question, hopefully someone can tell me whats wrong or has had a similar problem. i would really appreciate it!

So i was on the interstate and made a folish mistake and accidently left overdrive off just coming for a normal street, i was cruisin with one of my buddys and we were playing around and i got on it, i got up to around 110 mph and was paying attention and looked down i was red lineing and then i discoverd overdrive was off

since then something just doesnt seem right, when i get on it now the supercharger makes a wierd scream not like it usually did and i can almost feel some vibration in the pedal. i cant really describe it but something is not right. the truck starts up fine runs and shifts smooth, i know i didnt throw a rod or anything major like that, it makes not knocks or ticks but when i do get on it now i smell something funny, my buddy behind me smelt it and said it smelt like clutch. IDK!

please help, i know i made afolish mistkae :smt021
 

·
I paid my buck-o-five
Joined
·
75,542 Posts
sounds like you fried a plug...


but at least you didn't blow your motor by allowing it to shift into OD @ WOT
 

·
Undisputed Re-Post Master
Joined
·
14,354 Posts
Yea, you did a good thing by turning off the OD. If you had not, you would be posting here asking where to buy a new motor most likely.

Have you checked the motor bay for any coolant anywhere?
Check Vac lines, the one by the S/C (on the drivers side) is notorious for popping off.

After checking those two things I'd check plugs next.
 

·
George\/
Joined
·
3,421 Posts
Yeah if you feel it isnt running correctly pull the plugs and plan on replacing anyway.... they are cheap and you have to pull the once that are in it out anyway
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
ok so today i drove to school and work and its once again started fine and i checked for leaks like shaggy said but there was none i saw, there is one thing i noticed today that i didnt notice yesterday, as i gradually apply the throttle and get somewhere around 3000 - 5000 rmp thats when the scream of the supercharger doesnt sound right, its hard to describe but it has a raspy sound to it, is that the transmission not being able to shift or what?

also you guys have said check plugs and i dont wanna sound stupid but not realy sure what plugs your talking about? help...

also checked trans fluid when i got home from work and was past hot and was on the do not fill line, not sure if that helps but thought i would mention it
 

·
Registered
Joined
·
550 Posts
Spark plugs. Try getting it on video. I got a question though. do yall do runs on the highway with the overdrive off? I've never taken the od off but once in like 2002 and she redlined and bogged down (and got passed by a transam). All my wot runs since then have been with od on.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #12
the spark plugs are the plugs they are talkin about you can also check your belt it might be fried if its pretty old and it smells like a clutch burning
The belt was my very first thought when i first feard it but i dont know enough to tell if the belt is off , or slipping, or bad


im gonna do a video here soon.
 

·
Stiffler's guinea pig
Joined
·
6,603 Posts
I'm gonna have to say more than likely it is one of the two belts. I would get a light and do a visual inspection of them. Look for any burn marks on the inside of the belt, see if there are any chunks or "threads" hanging from either belt. Inspect it with the truck off. Too easy to lose a finger in there. You can put some marks on the belt, then start it and shut it off, so that the belt can rotate around to another spot you can check.

What area of the country do you live. Maybe there is someone on the forums here that could come over and have a look-see.
 

·
Guilty by Association
Joined
·
19,345 Posts
Rub your finger under the snout of the supercharger and behind the pulley to check for belt dust as well, how thick is the coating of powdered rubber under there?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #15
i live in south central kentucky

my camera is charging now so it will be a hour before i can get it on hear

ill go check the belt now (it dark so ill try my best)

p.s. thanks for the help! this is a great site!!!
 

·
Stiffler's guinea pig
Joined
·
6,603 Posts
i live in south central kentucky

my camera is charging now so it will be a hour before i can get it on hear

ill go check the belt now (it dark so ill try my best)

p.s. thanks for the help! this is a great site!!!
Yeah, it is a good site.

Let me ask you this, does it do the same thing if you rev it over 3000rpm while it is sitting still in Park? Or does it only do it while going down the road.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #18
lol i dont know him

i just checked the the supercharger belt and it has little slits on the inside of the belt but i didnt see anything that looked out of the ordinary such as big chunks missing or major wear, the teath on the inside of the belt look ok too, i checked for dust or whatever under the snout and there was some there, it was black, the alternator belt on the other hand looks fadded and brownish.
 

·
Guilty by Association
Joined
·
19,345 Posts
So acc belt is stock and the sc belt is prolly a gatorback. I'm not a fan of the gatorback and the acc belt is old IMO they should both be replaced, but thats just me.
 

·
Stiffler's guinea pig
Joined
·
6,603 Posts
Yes, I think you should start with the belts. Can you tell us how many miles are on the truck, and do you know what kind of mods have been done to it?
 
1 - 20 of 49 Posts
Top