Lightning Rodder banner
1 - 10 of 10 Posts

·
Registered
Joined
·
698 Posts
Discussion Starter · #1 ·
Hey everyone I just got my truck back up and running after reinstalling my transmission. We smelt something like electrical burn.

I was doing some testing I can get the L to start if I put a screwdriver between the starter relay post. So I know the starter is good. So thinking that the starter relay went bad. I went out to the store and bought a new one. That didn't work it still won't start with the key. But still will start if I use a screwdriver between the post.

So both new and old relays will start the truck with a screwdriver between the post.

What am I missing? Is there a fuseable link or regular fuse?
 

·
Registered
Joined
·
528 Posts
Is there play in the shifter handle? Try and move it up a little bit while you turn the key and see if it turns over.
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #4 ·
I think I got it might be a key cylinder problem. I jiggled the key in the cylinder and now it's turning over. I wonder it maybe it was a stuck tumbler in the cylinder since the truck hasn't been started in almost 3 months. Maybe I should spray some WD40 in the cylinder
 

·
Registered
Joined
·
1,072 Posts
Mine does this every once in awhile. I can pull up on the gear lever and it starts. I just haven't got back under it to adjust the linkage sensor(don't know what it's called), but it's slotted so it's adjustable.
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #6 ·
Ok so i didn't fix it. Its a intermediate thing now. Yesterday morning truck started up with the key. Took it to the dinner for breakfast. Got back in the truck started fine. Went out to a car show about 45 minutes away from my house. Walked around the show. Went to leave and then wouldn't start. Had to use a screwdriver on the starter relay. Then drove home put in the garage shut it off. Started it again with the key no problem. Let it sits for a few hours started right up with the key.

Maybe there is a loose wire somewhere. The only other thing i did to the truck was put new body mounts on. Didn't take the cab off just titled it up enough to get the mounts out.
 

·
Registered
Joined
·
698 Posts
Discussion Starter · #8 ·
WELL OP? Did you do that ^^^^^^
No doesn't seem to be any play in the shifter. When it happened the first time Joey- Redrum moved the shifter in different spots tried reverse,neutral & drive postions and it didn't do anything.
 

·
Stock Block [email protected]
Joined
·
3,279 Posts
No doesn't seem to be any play in the shifter. When it happened the first time Joey- Redrum moved the shifter in different spots tried reverse,neutral & drive postions and it didn't do anything.
:smt102 well damm, that sux.... let us know what you find....
 

·
Registered
Joined
·
760 Posts
double check there isnt any burnt wires or issues with the ignition switch under the steering column.
 
1 - 10 of 10 Posts
Top