Lightning Rodder banner
1 - 17 of 17 Posts

· Registered
Joined
·
2,542 Posts
Discussion Starter · #1 · (Edited)
So I'm a little confused. Where/how do the two hose ends connect? There were no clamps or fittings in the box and the two pressure ports on the kc look like I need a threaded adapter of some kind. After reading the instructions I think I'm missing some parts/fittings.
 

Attachments

· Registered
Joined
·
2,542 Posts
Discussion Starter · #2 ·
Hose
 

Attachments

· Registered
Joined
·
2,542 Posts
Discussion Starter · #3 ·
Hose 2
 

Attachments

· Registered
Joined
·
2,542 Posts
Discussion Starter · #5 ·

Attachments

· Registered
Joined
·
3,243 Posts
I am too,at least the a/c fittings bag,the coolant fittings bag and the coolant hose as shown in the install parts list sheet.Plus something won't let me download and print anything other than that 1st parts list page???:smt102:smt100
 

· Registered
Joined
·
2,542 Posts
Discussion Starter · #7 ·
Yeah I was pretty bummed. Wanted to install today.
 

· Registered
Joined
·
2,542 Posts
Discussion Starter · #10 ·
Left him a message yesterday morning. No reply so far. I'll try getting ahold of him tomorrow. Looks like the weather broke and cooler temps are forecast in the 10-day. I was just hoping to get some testing done in 90degree heat that we were having.
 

· Registered
Joined
·
2,542 Posts
Discussion Starter · #12 ·
Talked to Joe today and he said he would ship us out the parts missing today. :bigtu
 

· Registered
Joined
·
421 Posts
Sorry about the missing parts guys, I'm training a couple of new guys and I screwed up by not checking to make sure they packed the necessary parts for your kits. The missing parts are packed and going out today.

Again sorry for the inconvenience.
Joe
 

· Registered
Joined
·
76 Posts
MIKECR250,

Do you happen to have a pic of how you routed the line from the KC to the firewall a/c fitting? Installing a gen-3 kit and running into a problem getting it connected without interfering with the heater hoses or accumulator/dryer.
 

Attachments

· Registered
Joined
·
2,542 Posts
Discussion Starter · #16 ·
MIKECR250,

Do you happen to have a pic of how you routed the line from the KC to the firewall a/c fitting? Installing a gen-3 kit and running into a problem getting it connected without interfering with the heater hoses or accumulator/dryer.
I left the stock line in the truck in case I ever wanted to return it to stock. The new line follows the stock routing. I just moved the disconnected stock one over.
After that I ran the lines down in between the fender well core support gap.
 

Attachments

  • Like
Reactions: sshs99

· Registered
Joined
·
1,773 Posts
Sorry about the missing parts guys, I'm training a couple of new guys and I screwed up by not checking to make sure they packed the necessary parts for your kits. The missing parts are packed and going out today.

Again sorry for the inconvenience.
Joe
This is what has prevented me from purchasing a drag kit - poor quality control - parts missing - poor instructions etc. just seems like a hit or miss transaction to me.
 
  • Like
Reactions: FEARLE5S
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top