Lightning Rodder banner
1 - 8 of 8 Posts

·
A.K.A. SneakerWhore
Joined
·
2,479 Posts
Discussion Starter · #1 ·
O.k. guys I cant figure this out. Friday I was at the track with my truck. I mounted my slicks in the back and went down the track and I've got 2 problems I cant figure out for the life of me.

1, just about every run down the track the truck would pull to the left badly, but it doesnt do this with the 20s on. What could be makin my truck do this ???

2, with a 2# lower, and a 75shot the truck went [email protected] with a 1.89 60'. Friday I was catching 1.7 60's and I only ran 1 12.77 @ 105 and some low 13s and I've added a Ported Blower, and Long Tubes. I checked my solenoids and both are firing. I hit the purge and I see white stuff so I have spray in the tank...I know I'm running a lil rich, but come on a full second off my best ET...what in the world could be makin my truck do this ???

I was thinkin maybe the fuel filter but I dont hear any detonation so I dont think I'm going lean and I see 13# on the boost gauge, I'm really stumped and been racking my brain tryin to figure it out. Any of you have some ideas ??


Josh
 

·
George\/
Joined
·
3,421 Posts
the pulling might be a low tire, maybe one of the slicks?
and how hot out was it when running? although you were spraying you should still over come the heat, maybe not enough in the tank. how was the pressure?
 

·
Registered
Joined
·
348 Posts
my truck pulls when i am doing my burnout in the licks, but not down the track. you might want to check for tire pressure there. you could be running slower because of heat (outside), humidity (our trucks hate humidity), or you could have had low bottle pressure.
 

·
Registered
Joined
·
426 Posts
1) Check for tire/rim slippage on the LH slick.

2) Something is causing a loss in power because your speeds are down. Even on a hot day your trap speeds when shooting gas should be pretty close. Bottle pressure? Bad tune? Trans sliping?
 

·
Registered
Joined
·
348 Posts
thought more about it today, the first thing that keeps coming to mind is bottle pressure. do you have a bottle heater, was your pressure low.
 

·
A.K.A. SneakerWhore
Joined
·
2,479 Posts
Discussion Starter · #6 ·
Well today guys, the truck was runnin really frucked up on the way home from work....so me being an over paranoid maniac rushed to PSP to have him look at it. Sal Pulled my plugs and checked them all, all were pretty nasty but 2 were REALLY bad and my gap was slightly to big. So Sal installed a new set of NGKs properly gapped and bam my trucks running smooth again. While he was under the hood doin the plugs he happend to notice the lever on the side of the blower that closes to build boost, was stuck open. Sal was able to get it to close properly and then make it so it doesnt get caught up anymore. The trucks runnin 10000x better now and I think I found my problem between the plugs and the boost thing.

I've said it many times to many different people, but I'm gonna say it again....Sal @ PSP is the ^%$*$#% MAN. I cant even begin to say how great it is having him 20mins away when something aint right with my truck. Thanks Sal.
 
1 - 8 of 8 Posts
Top