Lightning Rodder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi
I need help to find out what a high sound can be when i drive over 15 mph it starts to come up a high sound also doing it when i am just rolling with out giving gas.
Any body any tought what i can check or do about it??
Thanks
 

·
Dude
Joined
·
2,290 Posts
Maybe a leaking Supercharger gasket or an air leak on the pressure side

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Its a high sound but almost not going up or down and making it just between 15 mph and 45/50 mph
 

·
Wile E. Coyote, Super Genius!
Joined
·
9,977 Posts
When I first did my blower swap, from Eaton to MP, I had a super high pitched whistling sound coming from somewhere. No idea where. I ended up taking everything above the blower off, and re-installing everything with black ultra RTV. Even after that it still did it, not as bad. Then went to bed one night, woke up and fired it up the next day, and it was gone. Fixed itself. Hasn't come back again. WTF??

I know it was an air leak whistle. And the sound never varied, while idling or driving, it sounded the same. Very weird. I have no idea what happened that it just went away on it's own. Sometimes I wonder if it will come back as quick as it went away.

When I use RTV, I don't do anything for 24 hours after putting it on. To allow it to fully cure. So it wasn't that.

Since I've been running a JLP sheet metal plenum from about 2014 on, it's the usual culprit for an air leak. First time I fired it up on the initial install back in 2014, had that horrible squeal. That time I was able to tighten the four plenum bolts and make it go away. When I did the MP swap last year, it was the problem once again. Tightening the bolts didn't work. That's when I went black RTV. The JLP plenum and the gasket are not identically shaped, the gasket being a lot smaller.
 
1 - 5 of 5 Posts
Top