Lightning Rodder banner
1 - 20 of 30 Posts

·
Registered
Joined
·
829 Posts
Discussion Starter · #1 ·
Hey guys my truck started acting a little funny. When its in park the rpm is moving up and down. Sometimes it even acts like its goin to turn off by dropping to 500 rpm. Kind of like it has a big cam. Could it be in the tune. By the way on d it is fine. Any help will be very apreciated. Thanks!!!!!!!!
 

·
Fat Bastad
Joined
·
2,756 Posts
Have you messed with anything under the hood lately? Installed CAI recently? Anything along those lines? Possibly forget to plug something back in or reconnect something? Or did this simply surface one day without any recent interventions on your part?

Roach
 

·
Registered
Joined
·
829 Posts
Discussion Starter · #5 ·
I have installed efans and a jlp tank but did not have to remove any lines wile doin it. and yes its only in Park. it does not matter if the ac is on or off either.
 

·
Registered
Joined
·
9,499 Posts
mine did that a few weeks ago, I forgot to plug in that big ass vac line to the midplate.

I would double check the vac lines. one may have accidentally gotten bumped off.
 

·
Fat Bastad
Joined
·
2,756 Posts
Did you remove any of your air intake when removing your stock fan? If so make sure you reconnected your MAF back to the wire harness. The truck will start and run without it being plugged in but it won't run right. Ask me how I know...:smt080

Roach
 

·
R.I.P #3005
Joined
·
3,733 Posts
could it be my intake its a little beat up
Not unless it leaking air, if it is it could be tossing the MAF counts off. Have you ever cleaned your mass air sensor I got some shit on mine once and it made the truck act up a little.
 

·
Fat Bastad
Joined
·
2,756 Posts
No i have not cleand it what can i cleand it with
Just walk into your local auto parts store and tell them that you want to clean your mass air sensor and they'll sell you a can of that you'll use to spray it with. Simply follow the directions. I've never done it but that's how I understand it to be anyhow.

Roach
 

·
Registered
Joined
·
3,645 Posts
No i have not cleand it what can i cleand it with
I would Clean the MAF with the red crc maf cleaner at the autoparts, while your at it also clean your IAC sensor and see if that helps.
 

·
Registered
Joined
·
3,645 Posts
Cool now sorry for this dum question wich is the iac sensor
No such thing as a stupid question.

Idle Air Control. Its the valve that on the left side of the plenum. Controls idle which is where your having problems. Just 2 bolts and comes right off.
 

·
Registered
Joined
·
9,499 Posts
For the MAF you can use the MAF cleaner or electrical contact cleaner, both by CRC. Get whatever's cheapest.

For the iac you can use brake cleaner or carb cleaner, spray the hell out of it, use a small screwdriver to compress the spring inside, and let it dry. Then give it a tiny squirt of wd40 or something similar.


---
- Sent from my iPhone 5
 

·
Registered
Joined
·
304 Posts
Do you live close to cypress? I'd be glad to give her a look-see. I have all the cleaners you would need. I also have tons of vaccum line and connectors. I also have 2 extra IAC valves if that is the problem. Give me a shout. 281-831-0167
Aaron
 
1 - 20 of 30 Posts
Top