Lightning Rodder banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
One of the simple tasks that has been on my list since I got this truck, was to restore the headlights. I finally had some time to do it, and it turned out pretty well. I have used the Mothers NuLens kits before, so I decided to use it again. The lights weren't too bad, but they definitely needed some cleaning up. The turn signals were in the worst shape.

Before:



After:



I did the restoration on the fog lights too. I originally planned on taking them out of the bumper, but it seems I have a bit of a retrofit going on here. The light output isn't great, and it seems the driver side is bottomed out on the bottom of the bumper. After looking at some threads, I think I have come to the conclusion these are some 01-04 fogs made to fit in my '99 bumper. Thoughts?





I also gave it its first hand wash since I bought it in January. Cleans up pretty good. Still a lot left to do though!


 

·
local painter
Joined
·
2,865 Posts
Nice work ??
 

·
Wile E. Coyote, Super Genius!
Joined
·
9,778 Posts
Those definitely are not the factory 2004 style fog light mounts. The factory mounts have the bottom adjuster mount staggered to the rear quite noticeably. WHen holding a set of latter model fog lights in your hands, the lower one is quite a bit further back than the two top ones. I just made some mounts for a friend with an 02 that has a 99/00 front bumper cover. No fog light mounts like mine has. I made mounts out of aluminum and staggered the upper ones forward, the lower one aft, to get them close to the factory style. He has them on the truck now, and they look stock. He's happy.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Those definitely are not the factory 2004 style fog light mounts. The factory mounts have the bottom adjuster mount staggered to the rear quite noticeably. WHen holding a set of latter model fog lights in your hands, the lower one is quite a bit further back than the two top ones. I just made some mounts for a friend with an 02 that has a 99/00 front bumper cover. No fog light mounts like mine has. I made mounts out of aluminum and staggered the upper ones forward, the lower one aft, to get them close to the factory style. He has them on the truck now, and they look stock. He's happy.
Did you make a thread about it? If I can’t get them to aim properly I might redo the mount.
 

·
Wile E. Coyote, Super Genius!
Joined
·
9,778 Posts
Yes I did.

 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Looks awesome! I'm just curious on how long it will last.
Thanks. I have 2 possible plans for this. Most likely when I get around to polishing and coating the paint, I will also put a sealant on the lights. It is a garage kept truck, so it will hopefully hold up ok. If that doesn't work, I'll clean them up again and spray them with a few coats of clear.
 

·
Wile E. Coyote, Super Genius!
Joined
·
9,778 Posts
Mine is a garage kept truck, and not driven regularly. I wash it maybe once a year. Mostly a California Car Duster is all that's required. And typically only the front end needs cleaning thanks to bugs. Anyhow, the lights on my 04 still look new. I did put new corners on a few years ago when someone on here was selling some without the reflectors. And new tail lights when I picked up some one-offs with leds and no red in them at all. So now my truck has no red in the back and no amber up front. Front corners are also now leds that lgiht up bright white in the running light mode and amber for the signals. Have a new set of "fogs" with HIDs in them that I am hoping to get on today or tomorrow.
 

Attachments

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Your lights are very clean. I looked at your thread on the foglight brackets. You don't happen to have any rough measurements do you? It doesn't look like it would be too complicated to replicate.

Are you 2A7X3 at Tinker?
 

·
Wile E. Coyote, Super Genius!
Joined
·
9,778 Posts
I can get them for you tomorrow. I have the factory lights off my truck now and the HIDs intalled and working. Thanks to Mike (blowerwhore) for helping me to get them working. Ends up you have to plug the factory plug into the ballast plug backwards for them to work. So the locking tab won't work. Should be okay though, it's a fairly tight plug.
 
1 - 12 of 12 Posts
Top