Lightning Rodder banner

1 - 20 of 23 Posts

·
Registered
Joined
·
1,691 Posts
Discussion Starter #1
Ok, in a nutshell. Truck was in the shop for 2 yrs, before that it ran strong chipped, pullied, intake/exhaust all was right with the world.

Truck comes out of the shop, driving... eh... Before any oil changes, flushes, filter changes i swapped my stock eaton for a Stieg Stage 4 eaton. with i'm pretty sure the same upper i used to have, added a new SBTB and retuned.

This is what its doing now. If i drive and give it any kinda power it holds its RPM to pretty much redline through every gear, then Shifts SOOOO hard, like torque converter, valve body, new tranny hard! thats just with kinda power, if i Full throttle and seems like it doesnt even want to shift at all.

We had it on the computer and was retuning the Diablo, the guy kinda new his stuff but i would def. say theirs better tuners out their, he lowered all the shift points and it still does it. He also said the Throttle body sensor is showing up faulty. So he said the SBTB might be staying open causing it to shift wierd.

The other thing i've noticed, that i didnt notice before sitting and new charger, is that when i just rev the engine say to 3-4k rpms, its comes back down to 1k sooo slow, like one stomp on the throttle to 4k and maybe 4-5 seconds later it drops to 1k.

But just cruising with no boost etc, it drives fine, shifts smooth, all good.

Other things i've done as well are PCV delete, EGR delete, got rid of the vacuum boxes for the A/C. So could I have a vacuum leak somewhere maybe?

What do you guys think is going on? if a sound clip or video might help lmk, and i can try and get that for you tomorrow.
 

·
paranoid
Joined
·
4,608 Posts
can you check the tps sensor.. maybe that is it .. dunno just a thought.. you can adjust the tps by checking it with the handheld..

mine did a similar thing when i changed out the sbtb.. also ..

had to set the volts( or whatever) at the tps
 

·
Carpe diem
Joined
·
10,810 Posts
when i put a new sbtb on awhile back mine did similar things but didnt rev that high before shifting pulled battery to reset computer and all was fine. have you tryed this at all
 

·
Registered
Joined
·
1,691 Posts
Discussion Starter #4
when i put a new sbtb on awhile back mine did similar things but didnt rev that high before shifting pulled battery to reset computer and all was fine. have you tryed this at all
I'm kinda a newb to the engine, where/what is the tps? Throttle positioning sensor?

Battery has been unhooked numerous times since back on the road, and it's been like this always
 

·
Building a fast catfish!!!
Joined
·
15,687 Posts
it right on the TB... the sensor you had to swap to it from the stocker
 

·
Premium Member
Joined
·
14,841 Posts
Does your truck have an upgraded valve body?...If it does and the shifting function has been set up in the tune it will shift very hard...It will also burn your pump up a lot quicker than normal...Since the RPM's are coming down slowly it might need a dashpot adjustment in the tune also.
 

·
Innovator of the Bombassani exhaust
Joined
·
2,428 Posts
Might want to try this out....I had the same problem as you when I got my built motor installed. Damn truck would shift so hard, I thought the trans was about to explode. I tried to pull some shift pressure out using the SCT Xcal 2, but it still shifted brutal. I fianlly had enough and installed the stock tune. Truck barely ran due to the B2400 Maf..... I reinstalled the custom tune and immediately felt a difference in normal driving shifting. I went WOT and it shifted like it did before the build. Not sure if the file got corrupted during install the first time, but all seems well now.

Hope you get it ironed out......Great looking truck!!!!
 

·
Paul's ClutchBoxes
Joined
·
1,388 Posts
can you check the tps sensor.. maybe that is it .. dunno just a thought.. you can adjust the tps by checking it with the handheld..

mine did a similar thing when i changed out the sbtb.. also ..

had to set the volts( or whatever) at the tps
Bingo. Check t/p and it's adjustment
 

·
Undisputed Re-Post Master
Joined
·
14,354 Posts
the guy kinda new his stuff but i would def. say theirs better tuners out their, he lowered all the shift points and it still does it.
Ok that first sentence is scary. Not going to lie.

Did he adjust shift firmness, not shift points?

When I played around with shift firmness on my tune, I thought I was going to snap my back or the tranny was going to explode when it shifted.

I backed out the firmness and all was good in da hood.
 

·
Premium Member
Joined
·
5,735 Posts
I would adjust the TPS to as close to .99 volts as possible & get a new tune from someone that knows what the hell they are doing ASAP!
 

·
paranoid
Joined
·
4,608 Posts
o.p. clearly only one way to cure this problem.... just tell me were i have to go and ill bring my trailer and take the truck off your hands since its been giving you trouble. and i know your stressed out...

LOL...

plug you handheld back in and your gonna have to adjust the tps voltage to .99 by unscrewing the tps. and manually ...
 

·
Registered
Joined
·
1,691 Posts
Discussion Starter #13
o.p. clearly only one way to cure this problem.... just tell me were i have to go and ill bring my trailer and take the truck off your hands since its been giving you trouble. and i know your stressed out...

LOL...

plug you handheld back in and your gonna have to adjust the tps voltage to .99 by unscrewing the tps. and manually ...
Haha sure.

I'm really not sure what the tuner did, he got rid of the egr code I was throwing for the delete, and adjusted something to do with the shifting. Maybe improved slightly but not really, but was doing all thus before he touched it so I can't blame anything on him.


But he did say, that their was a fault in my TPS and that it needs replacing? Would that be correct or is it able to be adjusted with the handheld and he didn't know?
 

·
Registered
Joined
·
254 Posts
Sell that slow truck, LOL
 

·
paranoid
Joined
·
4,608 Posts
just change it out.. they arent that much .. and you have to make sure they are adjusted ... you cant adjust it by the handheld .. the handheld just tells you how many volts are going to it .. you have to adjust it by moving the sensor
 

·
Not Fast Enough
Joined
·
1,932 Posts
Go to advanced and pick up a TPS from there. Cost me $35 give or take.
 

·
Registered
Joined
·
315 Posts
Sounds like a faulty TPS, I've gone through like 5 of them, I always break them trying to adjust the voltage lol. When the last one went, it did exactly what yours is doing now. Truck would hold the gear for ever and then it would shift extremely hard, I got a feeling that's what caused my tranny to start slipping from 1st to 2nd right now :(
 

·
Registered
Joined
·
1,691 Posts
Discussion Starter #20
Sounds like a faulty TPS, I've gone through like 5 of them, I always break them trying to adjust the voltage lol. When the last one went, it did exactly what yours is doing now. Truck would hold the gear for ever and then it would shift extremely hard, I got a feeling that's what caused my tranny to start slipping from 1st to 2nd right now :(
That's exactly what mine is doing. Can I adjust it myself or do I have to have a handheld?
 
1 - 20 of 23 Posts
Top