Lightning Rodder banner
1 - 17 of 17 Posts

·
Stock
Joined
·
349 Posts
Discussion Starter · #1 ·
It's been a long road. I pulled the engine on January 26th. The day I've been waiting for is tomorrow.
Going to get my 87 Mustang GT vert dyno tuned tomorrow. What's everyone guess on power?





Here's the specs on the motor.
347 10.2-1 compression
Roller 302 Block
Scat Cast Steel 3.400 Crankshaft
Scat Forged Steel I Beam Connecting Rods 5.400
Probe SRS 2618 Forged Pistons (Flat, TFS) 4.030
FordStrokers Custom HYD Roller Camshaft
Intake Exhaust
Adv Duration 274 286
Duration @ .050 224 237
Lobe Lift 0.359 0.354
Rocker Ratio 1.6 1.6
Gross Lift 0.574 0.566
Lobe Centerline 110 114
Open @ .050 2 BTDC 52.5 BBDC
Close @ .050 42 ABDC 4.5 ATDC
LSA 112
TFS Twisted Wedge Fast as Cast 190cc Cylinder Heads
Comp Cams Ultra Gold Rocker Arms 1.6
30lb injectors
Trick flow track heat intake
Anderson 4" power pipe
Pmas 80mm MAF
1 3/4 BBK long tubes
offroad h pipe 2 1/2"
Dynomax cat back 2 1/2"
373 gears
T5 trans

Video & dynoi sheet to follow.
 

·
Dual Money Pits
Joined
·
4,504 Posts
not a clue what that would put down but good luck, hope it goes well!
 

·
Florida>Texas
Joined
·
10,629 Posts
425hp..375trq
 

·
Florida>Texas
Joined
·
10,629 Posts
I would be thrilled with that.
I'm hoping for 400hp.

yea I was shooting for the clouds, but i dont see why you cant hit the 400hp mark
 

·
Florida>Texas
Joined
·
10,629 Posts
goodluck..
 

·
Stock
Joined
·
349 Posts
Discussion Starter · #9 ·
goodluck..
Thanks, but didn't have good luck

Well no numbers. I was having a slow start problem. I had it to one shop and they said it was fixed. It was better but not right. Steve @ Thunder said it was strarting like it had too much timing, but it doesn't. You unplug the TFI module and it cranks faster but still not right. We tried another ECM still no go. He said it just didn't sound right when it was running. It also was popping from the tailpipes. I left the car with him to hopefully fix it. If not I will either be burning it to the ground or pushing it into a canal.
More to come soon.

Here's a couple of teasers. More then likely I won't be there when it's tuned so this is all I have.

Click to watch video.



 

·
Florida>Texas
Joined
·
10,629 Posts
well that sucks..hopefully its something easy to fix
 

·
Dual Money Pits
Joined
·
4,504 Posts
sorry to hear, always a disappointment when something goes wrong at the dyno
 

·
Stock
Joined
·
349 Posts
Discussion Starter · #15 ·
The car pulls nice. I still have a few bugs to work out.
When I was installing everything I had to remove the right side header a few times. In the process I tore the gasket. I got a set of fel-pro header gaskets. I've read the BBK ones are junk. I almost changed the left side too, but said to myself, it's on there just leave it. Well the left side gasket is leaking. I guess I will be changing that out now.

Here's the dyno graph.

 

·
Florida>Texas
Joined
·
10,629 Posts
good numbers..Im sure there is alot more in it once you get the bugs worked out
 

·
Mr. Crossfire
Joined
·
16,162 Posts
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top