Lightning Rodder banner
1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Came out from dental visit and my gear selector wouldnt go into drive…. Wtf? Eventually figured out the trick to bypass it so i could get it home and found that the 5amp, fuse #15 under dash popped….. i threw another one in and keeps popping intermittently…. I cannot perform a certain function and make it pop. Sometimes it’ll pop 10 seconds after getting into truck and begin my destination, sometimes ill drive for 30 minutes. I cannot go on a single drive without it shitting the bed before the drive is over. Only popped once right when i directly plugged the fuse in.


i have the updated brake fluid sensor (updated harness with fuse)…. Tried unplugging it, same problems.

the GEM module doesnt seems to act wonky in any way… everything performs as it should on the truck (until the fuse pops)….. it never gets wet; i live in vegas.

brake switch appears to be the last culprit unless someone has something else for me to look at/try.

thanks in advance.

i have not performed any modifications to the truck.
 

·
Registered
Joined
·
317 Posts
It was late and I thought you had the "dreaded fuse 23" when I read the driving issues...

You could not get the gear selector to shift out of park into drive?
What "fix" did you do?
Whatever you did possibly cause the current issue you're having? Or, did these two issues happen simultaneously?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
Fuse 15 will cause the gear selector to get stuck.

Whenever i reinstall a new fuse, the gear selector frees up and the truck acts normal, but everntually sometime during the drive, the fuse blows and goes back to the same ol problem.

I turned the truck off, turned the key 1 or 2 clicks (no lights on dash) dropped it in neutral, then started the truck. From there i could go into reverse or drive.

I havent done anything to the truck before or after aside from replacing the fuse and unplugging the brake pressure sensor…..

the fuse still pops awhile after i replace it. Havent done any modifications to the truck or torn it apart in any fashion. Literally just drive it to work and home. No abuse whatsoever.
like i said, i pulled into my dentist office, came back out, started the truck, tried to leave and couldnt because the gear selector was stuck.

windows are inop, cruise control is inop, dome lights are inop…. All because of this fuse. This is why i am curious as to what to look at next.
Half tempted on driving around without a brake switch for a bit to see if it still blows the fuse
 

·
Registered
Joined
·
317 Posts

Post 13?

Isolating each system separately and disconnecting it to see if it stops the fuse from blowing is definitely one way to do it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
Mine already has the updated wire harness and sensor

I guess that’s going to be my only option 🙄😑
 
1 - 7 of 7 Posts
Top