Lightning Rodder banner
1 - 3 of 3 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
Any of you TX guys rplaced the back light cluster fuse?

Mine goes in/out randomly on my Lightning....:smt013 Backlightning on the cluster ONLY... Radio is good,HVAC good, light switch good, mileage.... every now and again....? If so, anyone in the DFW area willing to give me a hand sometime? Thanks in advance...

If not, I will tackle it myself and help someone else sometime....:smt023
 

·
Registered
Joined
·
291 Posts
Mine goes in/out randomly on my Lightning....:smt013 Backlightning on the cluster ONLY... Radio is good,HVAC good, light switch good, mileage.... every now and again....? If so, anyone in the DFW area willing to give me a hand sometime? Thanks in advance...

If not, I will tackle it myself and help someone else sometime....:smt023
When I did mine, the backlighting cluster fuse was in the fuse box above the emergency break. I think I put a 5 or 7.5 one in there about a month ago. I didn't have to take anything apart or anything. It only took about 2 seconds.

EDIT: Just noticed the date. Guess you probably figured that out already, huh?
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #3 ·
Nah, I have not messed w it.... It works and comes on like clock work after driving about 2 miles...?? Doubt it is a fuse... It has to be something to do with solder or connection... I see you are in Euless.... I was over in HEB yesterday in mine... I have business over there... Thank you for chiming in.


When I did mine, the backlighting cluster fuse was in the fuse box above the emergency break. I think I put a 5 or 7.5 one in there about a month ago. I didn't have to take anything apart or anything. It only took about 2 seconds.

EDIT: Just noticed the date. Guess you probably figured that out already, huh?
 
1 - 3 of 3 Posts
Top