Lightning Rodder banner

1 - 20 of 22 Posts

·
Innovator of the Bombassani exhaust
Joined
·
2,428 Posts
Discussion Starter #1
Got my email tune from Rick this morning......Applied and smiles across the face. I still have that miss I originally had, but I think a plug change will cure it. Reason I say that is when we first cranked it up and ran it about 2 miles....I was running on 7 cylinders (Coil pack not plugged in). Might have fouled out a plug. If that is not it...I am ropes end. Tune did not fix it. Swapped COP did not fix it. All hoses are connected....... Mystery. Other than that little miss...This truck is a BEAST!!!!!! Idles perfect and cruises like a dream. Thanks Amazon for the excellent customer service!!!!

Later
 

·
I Miss My L
Joined
·
6,552 Posts
yeah dyno tune on mine and runs great....not any issues since...ATS FTW
 

·
Built And Blown
Joined
·
2,136 Posts
I contacted Rick also about some tuning on my truck. Nice to see these threads with happy customers.
 

·
I Miss My L
Joined
·
6,552 Posts
made the 5 hour drive there to get tuned and would do it all over again.....actually plan on taking it to them again in the future
 

·
7th Fetzer valve, yeah...
Joined
·
2,143 Posts
Rick's awesome. It feels like I got an L for the first time again! Now I need wider rear tires.
 

·
Registered
Joined
·
300 Posts
AMAZON tuning is the best , they help me all time to tune my L and my cobra on kuwait !! [smilie=3g[smilie=3g[smilie=3g[smilie=3g
 

·
Innovator of the Bombassani exhaust
Joined
·
2,428 Posts
Discussion Starter #13

·
Genital Contractor
Joined
·
2,086 Posts
Rick tunes my truck as well. I do not see me going anywhere else for a tune.
 

·
Innovator of the Bombassani exhaust
Joined
·
2,428 Posts
Discussion Starter #16
UPDATE on the Miss:

While cleaning the engine (wipe down) I noticed something I did not see before. Not sure how I missed it but the PCV hose coming from the passenger side was NOT connected to the intake boot. It looked like it but it was not...... Letting tire shine dry then it is time for a test run. Hope this is the cure all to the miss.
 

·
THE PROPER WAY TO POWDER THAT ASS
Joined
·
7,531 Posts
That will cause an issue but not a "miss". What do you mean by miss. Is one cylinder not fireing at all,intermitent, or only under boost? with that hose off you could have had a lean condition and toasted a plug? Good luck and I am happy your happy ;)
 

·
Innovator of the Bombassani exhaust
Joined
·
2,428 Posts
Discussion Starter #18
Not the issue...... Truck idles smooth, runs great at WOT and cruises smooth as well. The problem I am having is ,for example, A car in front turns and I coast to slow down. When I get back into the throttle at around 3/4 throttle, it bucks like it has a miss. Basically put the truck under a load (like going up a bridge in O/D) it will buck and miss. I think it is a plug but I was hoping that pcv hose was the problem. Wonder if the hose popped off under boost??? Will keep an eye on that sucker for sure.......
 

·
Got BOOST?
Joined
·
1,204 Posts
Rick does awsome work I will be making that 4 hour drive again for sure
 

·
Administrator
Joined
·
18,137 Posts
UPDATE on the Miss:

While cleaning the engine (wipe down) I noticed something I did not see before. Not sure how I missed it but the PCV hose coming from the passenger side was NOT connected to the intake boot. It looked like it but it was not...... Letting tire shine dry then it is time for a test run. Hope this is the cure all to the miss.
If that hose was off, and you did any datalogging for the tune, you need to call Rick. The results will be skewed. If he sent a base tune for your mods only, then all is well. Change the dam plugs! Always the first thing suspect.

Jim

Oh, and nice to hear so many happy customers chiming in! We have some awsome vendors on Lightningrodder.
 
1 - 20 of 22 Posts
About this Discussion
21 Replies
17 Participants
[email protected]
Lightning Rodder
Join our Lightning Rodder community to discuss the supercharged Ford F150 SVT and Harley Davidson edition pickup.
Full Forum Listing
Top