Lightning Rodder banner
1 - 9 of 9 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Picked up this 1993 Lighting today, super excited because I have always wanted one. This one's in really nice shape compared to most other project cars I've owned. It does not crank but the motor is free. It needs some work but it's a survivor that's been in New England all of its life. I am now the third owner and intend to register this truck and drive it in the summer. It still has all of the original paperwork from the dealer. It's got a sound system that takes up the entire bed and has a hold cut in the cab for it. Will be taking that out. One of the challenges is going to be finding a tubular rear bumper since mine is rotted out.
 

Attachments

· Administrator
Joined
·
18,757 Posts
That is my old truck I bought new in '93! I hope to see progress pictures along the build.

This was the only vehicle I ever owned that did not get performance upgrades. That stereo setup had over $2500 worth of wire/cables/connectors in it! That at 1993 prices.

If I can answer any questions, feel free to ask. But all is really stock still so not sure if I can help with anything. Motor ran well when I sold it. A bit tired, but drove it daily until I parked it.

Jim
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Wow, that's awesome. Thanks for the reply. I plan to keep it mostly original as well. Do you happen to have any pictures of it from back in the day? I would love to see it. I will be sure to post updates as it comes along. My goal is to drive it to Carlisle for the Ford Nationals in June. Did the stereo system still work the last time you drove it?

That is my old truck I bought new in '93! I hope to see progress pictures along the build.

This was the only vehicle I ever owned that did not get performance upgrades. That stereo setup had over $2500 worth of wire/cables/connectors in it! That at 1993 prices.

If I can answer any questions, feel free to ask. But all is really stock still so not sure if I can help with anything. Motor ran well when I sold it. A bit tired, but drove it daily until I parked it.

Jim
 

· Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Another question, why was the truck parked? Was there some kind of major mechanical issue?

That is my old truck I bought new in '93! I hope to see progress pictures along the build.

This was the only vehicle I ever owned that did not get performance upgrades. That stereo setup had over $2500 worth of wire/cables/connectors in it! That at 1993 prices.

If I can answer any questions, feel free to ask. But all is really stock still so not sure if I can help with anything. Motor ran well when I sold it. A bit tired, but drove it daily until I parked it.

Jim
 

· Administrator
Joined
·
18,757 Posts
It ran fine when parked. I had just picked up a 4wd Bronco to drive thru the Winter. Was planning to restore the Gen1. Stereo worked at that time. Not sure what year that was. At least a decade ago.

Jim
 
1 - 9 of 9 Posts
Top