2000 Lightning/No Power to fuel pump.. - Lightning Forum | LightningRodder.com
 3Likes
  • 3 Post By Certified Drunk
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-12-2017, 06:31 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 18
Rep Power: 26
 
Hello I'm been a member for a few years buy just usually read along and can figure out my issue nut none covered this. So while driving my 2002 Lightning i had small incident with a wide tree stump, just clipped my cab corner.. So, I changed out my cab and found another black Lightning but it switched to an 04..I used my Steering column and some things in the column were a little different but everything plugged up with a little manipulation... Now.. It started up at first for a sec or two but then sounded like it ran out of gas and I heard no pump.. So I checked the power to the pump.. (Bed is off) No power.. ?... Ok all fuses are good.. Relays I swapped out with my old dash I know they work.. I tried to jump the relay but still no power to the pump.. ??.. I'm thinking a Ground I missed maybe, its not the theft because it started and no theft light...and the funny thing is when I plug in my SOLOUS and check the the freeze frame data the fuel system is the only one that reads complete... Lmao.. Can any of you think of anything off the top of your head that would directly effect the fuel pump.. Also as if I needed another issue, when I hit the horn the right signal lights up in the dash cluster.
THANKS SO MUCH for any insight...

Last edited by Mike Diodato; 11-13-2017 at 07:51 PM. Reason: Wrong year
Mike Diodato is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-12-2017, 07:00 PM
E85R Space Dust
 
Certified Drunk's Avatar
 
Join Date: Jul 2009
Location: Seattle, WA.
Posts: 9,095
Rep Power: 71583193
           
Check the Intern switch.
It's behind the toe kick panel on the passenger side..
stoffer, 03F150HD and Capt.EKB like this.

The foot say's go, The light say's no!
Certified Drunk is online now  
post #3 of 4 (permalink) Old 11-12-2017, 07:26 PM
I paid my buck-o-five
 
stoffer's Avatar
 
Join Date: Nov 2007
Location: missing Texas...
Posts: 73,130
Rep Power: 71585347
           
/\/\/\ that

stoffer is offline  
 
post #4 of 4 (permalink) Old 11-13-2017, 07:56 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 18
Rep Power: 26
 
Yes I checked it it gets power.. And I changed it out, to be sure.. I'm hoping switching from a 2002 to a 2004 cab won't be an issue.
Mike Diodato is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lightning Forum | LightningRodder.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome